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Chapter 4.03: Updating Route
Manager Via the Web

Overview

This chapter will guide you through the process of
updating your Route Manager program via the
Internet. Depending on your Internet connection,
computer specs and size of data, this process may
take up to 2 hours to complete. Be sure to allow
enough time for completion of the update.

The update consists of 3 major steps:

1. Make a Backup of your data.

2. Downloading the update program file.
3. Installing the update.

These steps are covered below.

NOTE: ALWAYS make sure to make a backup prior to
installing any updates.

Making a Backup

Before proceeding with making a backup, ALL users
must be logged completely out of Route Manager.
If you attempt to make a backup and a user is
logged in, you will be notified that you cannot
proceed and have all users log out.

The first step in making a backup, aside from having
all users logged out is to make sure Local Settings
has a Backup Directory established. Navigate in
Route Manager to File > Local Settings and then the
Directories tab.
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File | Lists

Import...
Export...

Pack

Print...

Logout

Eranch Setup

Local Settings

Messaging 2

Load Data Set
Manage Data Sets

Rebuild Data Files

Backup/Restare 2
Print Setup... Ctrl+P

Exit and Logout

Transactions  Reporf

Locate the Backup Directory setting. If this is blank
or pointing to a path that no longer exists, be sure
to put a valid path in the field. Using the value of
“\Backup” will create the backup within the
RMA\Backup folder, and should be sufficient in

most cases.

S YSTEMS

“4 Local Settings

Local Settings

Direciories

Desktop 1 Communications Directories IPrlnters 1 Reports ] Colors I

Backup Directory | \BACKUP

GIL Output D\rec‘tury‘

Credit Card Processing Directory ‘

I~ Backup

Bank Transfer Processing Directory ‘

EF2000 Document Directory ‘

EF2000 Equipment Document Directory ‘

Report Qutput D\rec‘tury‘

Mapping Directory ‘

Photo D\rec‘tury‘

MapPoint Templats Fils |

E=8 HoR =
il I~ Backup =
X |

Save the changes to continue.

Next, navigate to the File > Backup/Restore >
Backup Data Files menu item.
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Lists Transactions Reports Route Tools Module

Branch Setup H@ j

Local Settings
Messaging 3

Load Data Set
Manage Data Sets

Import... »
Export... 4
Rebuild Data Files

Pack

Backup/Restore 4 Backup Data Files

. Restore Data Files
Print...

Print Setup... Ctrl+P

Logout
Exit and Logout

Upon choosing the Backup Data Files option, a new
screen will appear letting you know the Data folder
that is being backed up (C:\RMA\DATA in the
example below) as well as where it is being backed
up to (C:\RMA\Backup) as well as the file name
(rm2kd.zip)

Rmadvanced Backup

CARMA\Data

This will make a DATA BACKUP from
:l to CARMABACKUP\RMZKD ZIP

Cio you want to continue?

Comment

fes ‘ Mo ‘

Enter a comment in the Comment Box, such as
“Prior to Version 7.0.2 r1 Update” (or whatever
version you are installing). Then choose the Yes
button to proceed.

The backup process will proceed and a .zip file will
automatically be created in the folder that was
mentioned in the previous screen.

Example of the backup in progress:
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|Creating Zip File: \BACKUP\RM2KD ZIP
|Compressing: ARSWizard/Data/CustomerData.xml

| 0%

ENTERPRISE

Once finished, a notification will appear letting you
know the backup has completed:

L]
RMAd: ed Backup/Rest... |
Vanc ackup/Res -

Backup Completed

Select the OK button to finish the backup process.

Downloading the Update

Using your web browser, browse to our support Web
site at www.ARS247.com

NOTE: Updates must always be installed on the Main
PC/Server that Route Manager was originally installed
on. It can NOT be installed from a workstation or mapped
drive.

1. Login to the site by clicking the LOG IN option in the
upper right corner then entering your Cl Code and ZIP
code.

Click the Support drop down menu.
3. Then choose the Downloads option.
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4. Select Route Manager Advanced from the list of
options under the Software Download section.

5. Choose the latest RM Series update available.

6. Review the release notes, make note of any special
warnings/precautions.

7. Download the file to your PC by selecting the
Download link on the right of the screen or at the
bottom. Make note of where the file is being
downloaded to, as the next step will require you to
double click the file to begin the update process.

8. After the update has been downloaded, and backup
completed, double-click on the file.

NOTE: All users must exit Route Manager before continuing
and a backup should always be made prior to installing an
update.

Installing the Update

Once the backup is complete, and you are sure you
are working from the Server/Main PC where Route
Manager is installed, double click the update file
that was downloaded from www.ARS247.com.

Depending on your operating system, you may
receive a warning (similar to the one shown below)
from Windows asking for your permission for the
update to make changes to the software on the
computer, select the YES button to continue.

|@ Do you want to allow the following program from an
unknown publisher to make changes to this computer?

Program name: rm2kAdvE21r.exe
Publisher: Unknown
File origin: Hard drive on this computer

Change when these notifications appear

(%) Show details

After the file is extracted, continue to follow the
instructions listed below.

The first screen will be the Welcome screen, please
review and select Next to continue with the
installation process or Back to view previous pages
or Cancel to cancel the update process.
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1 Route Manager v7.0.1r8 7900 Setdp = =

Welcome to Route Manager v7.0.1r8
7900 Setup

Setup will guide you through the installation of Route
Manager v7.0, 1rd 7900,

It is recommended that you dose all other applications
before starting Setup, This will make it possible to update
relevant system files without having to reboot your
computer,

Click Mext to continue,

Next > Cancel

You will now see the License Agreement screen.
Carefully read the license agreement. If you agree
to the terms outlined, select | Agree to proceed.

1 Route Manager v7.0.1r8 7900 Setuf = =

e L A i
Please review the license terms before installing Route Manager

ROYTE MANAGER V70118 7900.

Press Page Down to see the rest of the agreement.

Software License Agreement -~

IMPORTANT - READ CAREFULLY BEFORE OPENING SOFTWARE ANDJOR USING
SOFTWARE. By opening the sealed package containing the software andjor using the
software, you indicate your acceptance of the following Software License Agreement.

This saftware license agreement, induding Warranty and Special Provisions set forth in

the appending or separate booklet induded in this package is a legal agreement between
you (either an individual or an entity) and Advantage Route Systems, Inc. By opening

the sealed software packets andjor using the software, you are agreeing to be bound

by the terms of this agreement. If you do not agree to the terms of the agreement, ¥

If you accept the terms of the agreement, dick I Agree to continue. You must accept the
agreement to install Route Manager +7.0. 1r8 7300.

< Back I Agree Cancel
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Select an Install Type and then choose Next to

continue.
A Route Manager v7.0.1r8 7900 Setdp = =
—a Choose Install Type
Select the install type to run,
HOUTE MAMSEER

(®) Full Install or Update Existing Install (Standard)
(") client Install {Used for Secondary Mapped Drive Installs)

(_JRM2000 Conversion {Used for Converting from RM2000)

< Back Next > Cancel

NOTE:

Full Install or Update Existing Install (Standard):
Select this option to update your existing Route
Manager installation or install Route Manager on a
new server. This option is selected by default, as it’s
the most common.

Client Install (Used for Secondary Mapped Drive
Installs): If your network environment is setup to
map workstations to the Route Manager main
computer/server via a Mapped Network Drive, use
this option to update the workstations with the
proper .DLL and Registry entry files.

RM2000 Conversion (Used for Converting from
RM2000): Only use this option if you are converting
data and upgrading from Route Manager 2000 to
Route Manager Series 7.
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Enter or browse to your Route Manager program
location to be updated. If you have a previous
update in the past, it will remember the last
location provided.

A Route Manager v7.0.1r8 7900 Setuf = =

= Chocse Install Location
Chonse the folder in which to install Route Manager v7.0. 1r8

ROUTE MAMIGER 7500,

Please choose the Route Manager directory:

RMA Path

CriRMAY Browse...

Space required: 222.8MB
Space available: 108, 1GE

< Back Install Cancel

NOTE: The default Route Manager path is C:\RMA,
however, your Computer Administrator may have
installed Route Manager on a different drive or
folder. The easiest way to find the location of Route
Manager is to right click on the shortcut located on
your servers desktop and choose the Properties
option. The Start In path is where the Route
Manager folder resides. Normally this will be on one
of the following drive letters: C, D, E or F. Anything
higher may indicate you are using a Mapped
Network Drive to connect to the program and an
update should never be performed via a Mapped
Network Drive.

After clicking Install, the setup program will

proceed to copy files and install the update and
rebuild the database tables. This process may take
several minutes to hours depending on the speed of
your machine, amount of history, and previous
version you were on. If you wish to quit the
installation at any time, choose Cancel on the
progress bar. But be aware, cancelling in the middle
of the update may have unstable results.

Series 7.1.X 8



La
LUADVANTAGE

A A4 ROUTE S YSTEMS
wwww, AdvantageRoutecom

1 Route Manager v7.0.1r8 7900 Setuf =
el Installing
Please wait while Route Manager v7.0, 1r& 7900 is being installed.
HOUTE MAMIEER
Extract: RMA.EXE
Show details

When the installation is complete, the following
screen will appear. Read the information on the
screen and then click Finish. The update is now
complete.

Ay Route Manager v7.0.1r8 7900 Setuf =

Completing Route Manager v7.0.1r8
7900 Setup

Route Manager v7.0. 1rgé 7900 has been installed on your
computer,

Click Finish to close Setup.
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Update Tips

1.

Series 7 of Route Manager has four different flavors of
the software, and can be identified by the Title Bar of
the Application or the default background screen
image. The different flavors are:

a. Lite
b. Pro
c. Advanced
d. Enterprise

Each update has a unique build number and date
displayed in multiple locations within the program, for
example:

0 The Help > About Route Manager Series 7
(Flavor: Enterprise, Release: 7.0.2t, Build
8553, Industry: General)

RN

Advantage Route Systems, Inc.

3201 Liberty Square Plwy

Turlock, CA 95380

Phone: (209) 632-1122

Fax:  (209) 632-6868

E-Mail Support@AdvantageRS.com

Web Site: www AdvantageRS.com

Version 7.0.2t 8553 Date 04/18/16
©1994-2016 Advantage Route Systems Inc.

Version7.0.2t Build 8553 Date 04/18M16

General Enterprise

ENTERPRISE VERSION

Registered To:
Advantage Water and Ice
3201 Liberty Square Parkway
Turlock
[ RMA Serial#:
Cl Code:
User Licenses:
CE Handheld Licenses:

System Date 04/18/2016
System Time 07:35:40

Tables | Error Log

0 The Title Bar at the top of the
screen/program: (Flavor: Enterprise, Release:
7.0.2t, Build 8553)

Made in the USA E

| AM Enterprise v7.0:2¢ (8553) - Advantage Water and Ice [ADMINISTRATORZ]
File Lists

Module Date 0471812015 @@@D@@ Period MO_APR 2016 @@ E Augr_at

Transactions Reports Route Tools Modules Inventory Window Help

This makes it easy for you to identify if the update was
successful after the installation.

When installing the update, if you receive the
message “An error occurred during the move data
process,” this means that files are locked by other
users. Even if you have logged everyone out of Route
Manager, the files may be “stuck” on the network.

Series 7.1.X
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The simplest resolution to this problem is to reboot
your File Server.

4. If trying to log into Route Manager, and you receive a
message about “Rebuilding or Packing Data. Try again
later.” Then you will need to perform the /REMLOCKS
command. Do this by going to Start > Run, and
entering the FULL RMA.exe path and adding a space,
then /REMLOCKS at the end. Example:
“C:\RMA\RMA .exe /REMLOCKS”

NOTE: This is covered in more detail on ARS247.com.
Log into the website and search for REMLOCKS.

5. Always install updates directly on the File Server/Main
PC.

6. Make sure you have adequate network security
(Administrator) privileges before attempting an
update.

7. When updating a Terminal Services enabled Server,
make sure you are in “Install” mode or install the
update via the Add/Remove Programs menus.

NOTE: Failure to install updates in “Install Mode” may
result in an unstable operating system environment.

8. You can also view Release Notes for your version at
any time by going to www.ars247.com, logging in and
then going to Support > Downloads > Route Manager
Advanced and then choosing your version.
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Copyright © 1994-2016 by Advantage Route
Systems, Inc. All Rights Reserved.

Printed in the United States of America.

Advantage Route Systems, Inc.
3201 Liberty Square Parkway
Turlock, CA 95380 USA

Phone: 1.209.632.1122

Web Site: www.AdvantageRS.com

Email: info@AdvantageRS.com

Warning

All information in this document and the on-line
help system, as well as the software to which it
pertains, is proprietary material of Advantage Route
Systems, Inc. and is subject to a Route Manager
license and non-disclosure agreement. Neither the
software nor the documentation may be
reproduced in any manner without the prior
written permission of Advantage Route Systems,
Inc.

Series 7: Version Date, April 18, 2016
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